PSP downgrader for v3.03 released


While I was on vacation, [Fanjita] and [Ditlew] released a downgrader for PSPs running v3.03 firmware. To get it to work, you’ll need an unpatched copy of the GTA:Liberty City Stories UMD. The hack should get you down to v1.5. It’s supposed to work on all current PSP hardware. Thanks to [wraggster], [Steve DiRaddo]. [Sean] submitted the same info [via noobz], but they don’t appear to have credited the authors. (Unless of course, the authors are part of noobz.)